Service Provider Degraded Performance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Sep 13, 2023 - 21:15 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Sep 13, 2023 - 18:15 SAST

Update

We are continuing to investigate this issue.
Posted Sep 13, 2023 - 17:48 SAST

Update

We are continuing to investigate this issue.
Posted Sep 13, 2023 - 17:48 SAST

Investigating

We are experiencing an issue resulting in degraded performance on a number of services. Our team is working hard to resolve this issue and restore the service as quickly as possible. The impact here is limited to a minority of service events and an update will be provided soon.

All Stitch services and payments are operational during this period of degradation.
Posted Sep 13, 2023 - 15:58 SAST
This incident affected: Stitch (Stitch API, Bank Account Verification Service).