Card Service Provider Degraded Performance

Incident Report for Stitch

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 18:20 SAST

Update

We are continuing to monitor for any further issues.
Posted Apr 14, 2025 - 17:48 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 17:23 SAST

Identified

We identified an issue with one of our downstream service providers, resulting in a period of degraded performance that is impacting wallets transactions (ApplePay, GooglePay, SamsungPay).

Our team has contacted the provider for a better insight into the problem. We're monitoring this closely.
Stitch's core platform is fully operational and other services are unaffected.
Posted Apr 14, 2025 - 16:26 SAST
This incident affected: Card (Service provider).